Reply To: Please read I need your Help

Home Forums Help, questions Please read I need your Help Reply To: Please read I need your Help

#22644

Khutori
Member

Yes. the new updated peterbilt tuck it worked for me and its awesome Peterbilt_379_v2_by_Zolee it is in a MAN dealership and you need to be lvl 19 <<<
as promised just letting you know buddy just make sure your running Version 1.8.2.3
all the best keep trucking