BOTTOM SLOT next gen V 1.0

THIS MOD IS FOR YOU!!!

Guys I will please everyone …
Because I have received many requests from you.

But I think this is really a fantastic job and I definitely think you like it !!!

-Works with mod for Scania S

LEAVE THE ORIGINAL LINK !!!

Credits:
Matt_07ita

DOWNLOAD 36 KB

11 thoughts on “BOTTOM SLOT next gen V 1.0

  1. thank you but works not with eugene scania

  2. i test it on a clean profile but it works for SCS Scania NextGen not….. please fix it thank you

  3. NON FUNZIONA
    Matt_07 se fai una mod in formato zip con password e poi cambi estensione in scs NON FUNZIONA.

    the mod doesn’t work because it is ZIP format with password. then the extension was changed to SCS.

  4. Don´t know what you mean with “fantastic job”, the mod doesn´t work.

  5. Matt_07ita

    Grazie .Risolvo subito

  6. Matt_07ita

    Ho creato il FIX.LO CARICO STASERA DOMANI ARRIVA IL ZIP

  7. GermanETS2Driver

    Still it replace the low bar from SCS… and why is the Mod picture, description and the manifest locked? Pls let the manifest open or delete the sentence “compatible version 1.39” so it runs on other versions.

    1. can you make it for 1.38

      1. GermanETS2Driver

        No because the Manifest is locked from the Modder… in every Mod from him he let it open for privat edits of course but in this its locked so sry the Modder have to make :/

  8. Funktioniert leider nicht

  9. Der Mod funktioniert nicht

Leave a Reply

Your email address will not be published.

Human Verification: In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.