Fix for RJL Sisu R500 C500 C600 ETS2 1.35.x

Fix for SISU R500 C500 C600 for Euro Truck Simulator 2 v.1.35.x

This fix update the SISU R500 C500 C600 truck to version 1.35,x of Euro Truck Simulator 2.

For it to work properly this mod must be placed just above the original SISU R500 C500 C600 truck mod.

You need have the original mod of the RJL SISU R500 C500 C600 truck. You can download at the following link: https://forum.scssoft.com/viewtopic.php?t=167433

PLAEASE DO NOT REUPLOAD OR EDIT WITHOUT MY PERMISSION!!!!

Credits:
Anarook

DOWNLOAD 6 MB

4 thoughts on “Fix for RJL Sisu R500 C500 C600 ETS2 1.35.x

  1. original mode is incompatible, what should I say I wonder

    1. “The incompatible feature is specified by the mod maker in the manifest file. You can edit it manually if you know how to open their mods”
      Add this line: compatible_versions[]: “1.35.*”

    2. TheGreenlightTrucker

      Or just delete every compatible_versions[]: “###” line.

Leave a Reply

Your email address will not be published.

Human Verification: In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.