Sort by: Game Version

Home Forums Suggestions, ets2.lt information Sort by: Game Version

This topic contains 0 replies, has 1 voice, and was last updated by  PryMary 3 years, 2 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #91227

    PryMary
    Member

    Hi all,

    I would like to be able to sort the mods by game version so all the mods that I am downloading are compatible with the latest release of ETS 2 – Especially now that 1.19 is out and has the MOD Manager I think this is going to be crucial to avoid players downloading outdated / incompatible mods when there is a compatible one available.

    Thoughts?

    Pry

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.