Realistic Rain & Fog & Thunder Sounds v 3.9

YouTube preview

Realistic Rain & Fog & Thunder Sounds V3.9 For ETS 1.34.x

Features & News In Rain & Fog & Thunder Sounds V3.9 Version:

* Compatible With TSM, ProMods, RusMap, EAA and Other Maps Too.
* Compatible To Work With ETS Game Version 1.34.x
* 4 Realistic Thunder Sounds.
* Realistic Thunder Sounds Inside Cabin & Outside Cabin Of The Truck.
* Realistic Rain Drops/Windshield Effects.
* Improved Rain
* Imrpoved Rain Effects
* Improved Quality Of the Water (E.g: Sea & Rivers etc)
* Improved Rain Particles/Spray (Truck & AI Traffic)
* Different Types Of Weather
* Different Rain & Fog Intensity

Realistic Rain & Fog & Thunder Sounds V3.9 Updates:
* Update For ETS 1.34.x
* Rain Tweak
* Compatible With All Maps
* Water Particle/Spray Tweak
* Some More Tweaks In The Weather & Fog
* Fixed Few Other Things

Important: Do not use with any other Weather type mods Disable them.

Please Do not Re-upload in any other hosting site/s keep the original download links. Thanks

SCS Forum: https://forum.scssoft.com/viewtopic.php?f=34&t=166418

Videos Courtesy and Thanks To FoxontheBox & Neranjana

Credits:
Kass

DOWNLOAD 89 MB

14 Responses to Realistic Rain & Fog & Thunder Sounds v 3.9

  1. Luki38 says:

    Jest tez taki mod do wersje 1.33

  2. Canarinho says:

    Must i use Version 1.7 to? What is the different of this 2 mods?

  3. Dek-Top says:

    Works but the guard rails are illuminated in the dark.
    Mod installed in high priority and no other season mod installed. Bug or modification to be made? Thank you for your return, good job I love!

  4. Rodrigo says:

    Amazing mod, perfect on EAA MAP!!
    From Brazil.

  5. Vexa93 says:

    Is this compatible with v1.33.3.1s version?

  6. nick says:

    will it work with weather mods like this? – https://ets2.lt/en/new-weather-v-1-5-schumi-1-33-1-34/

    and will it work with sound fix pack and promods/rusmap??

  7. nick says:

    will it work with sound fix pack, promods, rus map and New Weather mod by schumi

  8. Vexa93 says:

    Is this compatible with v1.35 version?

Sponsored links

Leave a Reply

Your email address will not be published.
Before commenting read

Human Verification: In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Popular mods