I see v1.1.4 and also v1.7. Confused!

Home Forums Help, questions I see v1.1.4 and also v1.7. Confused!

This topic contains 0 replies, has 1 voice, and was last updated by  manwithdog 3 years, 9 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #61495

    manwithdog
    Participant

    As a slight ‘noob’ to the mod scene, when I am looking through the mods I am confused as to all the variety of versions.
    For instance, I am currently running ETS 2 version 1.1.4 with a few mods installed. But I keep seeing mods that are apparently compatible with version 1.7? Now I know that my version can be updated by Steam to v1.1.5, but where is this v1.7 come from? I don’t get it?

    I am really keen to try some mods on here, but because they say v1.7 and not v1.1.4, I assume they will not work?

    Can anyone clear this confusion up for me?

    Would be very much appreciated.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.